Jump to content


Photo
- - - - -

Warning: Tinymce Problem With "register_globals" Enabled


  • This topic is locked This topic is locked
1 reply to this topic

#1 matt.simpson

matt.simpson

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 7,655 posts

Posted 02 December 2008 - 01:12 AM

Important Warning:

If you have register_globals enabled in your PHP installation still, then you will have major problems if you are loading the TinyMCE rich text editor. I am attempting to find a work-around for this, but it's not going to be an immediate fix. Please disable register_globals in your servers php.ini file or talk to your web-hosting provider about this today. PHP should not be running with register_globals on.

If you need to disable it, you can create a .htaccess file and place it in your ListMessenger application directory with the following code in it:
php_value register_globals 0

For more information on why register_globals is *terrible*, please see php.net: http://www.php.net/register_globals

Best Regards,
Matt Simpson

#2 Lipak

Lipak

    Poster

  • Forum Members
  • PipPip
  • 15 posts

Posted 03 December 2008 - 03:45 PM

If you receive a “500 Internal Server Error” message when implementing the above code into your .htaccess file (this most likely occurs due to the server running PHPsuEXEC) you can alternatively try creating a php.ini file with the following code in it:
register_globals 0
Or
register_globals = off
The only thing is that unlike the .htaccess file, you will have to place the php.ini file in every directory that contains a .php file within [LM Installation]/ javascript/wysiwyg/tiny_mce/plugins/ (that’s around 19 directories – more if you do this installation wide)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users